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Accessing your Blue Prism Cloud platform
This guide details how to access your Blue Prism Cloud Digital Workforce platform along with other 
items of useful information.

Architecture
Details of the Blue Prism Cloud architecture can be found in the Blue Prism Cloud Application 
Architecture data sheet which is available separately.

Running Remote Desktop
To access your Blue Prism Cloud Workforce you will need to use an application called Remote Desktop 
Connection.

To access Remote Desktop Connection:

 1. Right-click on the Windows start button and select Run.

The Run dialog displays.

 2. In the Open field, type mstsc and click OK.

Remote Desktop Connection opens.
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Logging into the Management Server
Before attempting to RDP to the Management Server (MS) on your Blue Prism Cloud platform, should 
ensure that you have successfully initiated a JIT (Just in Time) VM access request to the Management 
Server. Instructions on how to do this are detailed in the Azure Management document.

JIT is not applicable for BPC Platforms where customers are RDP-ing to the Management Server using 
the private IP address, i.e. the site-to-site VPN.

 1. In Remote Desktop Conntection, type in the internal/private IP address of your Management Server 
in the Computer field.

The server details such as Private IP, Machine Name, Windows Username and Windows 
Password should already be with the requested end user upon your Blue Prism Cloud Platform 
Handover. If you do not have the server details of the Management Server, then please email 
cloudsupport@blueprism.com to request for these to be shared.

The Windows Security dialog displays.

 2. Enter your provided credentials: username and password.

Management Server Desktop
Once logged in you will be able to see the Management Server desktop. It is important to note that no 
automations are run on the Management Server – the purpose of this system is the management of the 
digital workforce and is seen as a staging and control area for the automations.

From this desktop, you can do two things:

 • View and control the Digital Workers

 • Restart an automation.
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Accessing the Digital Workers
To access the Digital Workers for operator or developer activities, or at times IT support access the 
method below is recommended.

VNC to a Digital Worker
 1. Open the folder on the Management Server desktop named Virtual Worker Access. Inside the 

folder there will be shortcuts for all of your Digital Workers.

 2. Double click the shortcut for the Digital Worker you want to access.

The Vnc Authentication dialog displays.

 3. Enter the appropriate VNC account credentials for the Digital Worker being accessed. The VNC 
connection is made using admin mode which enables development or configuration work to be 
performed.

 4. Click OK to open a VNC window to the Digital Workers desktop.
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VNC Restrictions
You can apply the following restrictions on Digital Worker usage to ignore mouse and keyboard inputs, 
and prevent access to clipboards.

 1. Click the connection button from the menu bar.

The Connection Options dialog displays providing access to the Restrictions options.

 2. Apply the required restrictions:
 • View only – If you make sessions view only, any mouse and keyboard inputs are ignored.

 • Disable clipboard transfer – This option should be selected to prevent Digital Workers from 
attaching to your local clipboard, or other Digital Workers clipboards, causing confusion in 
the automation and leading to a potential system exception.

 3. Click OK to save your settings.

Shutting down/closing open application
VNC should be treated like any other application, therefore when a system exception has occurred, Blue 
Prism recommends that you close all applications that are currently open on the Digital Worker’s desktop 
using the correct methods to log out and close applications. After closing all automation utilised 
applications, you should close the VNC window.
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Accessing Blue Prism

Logging into Blue Prism
From the Management Server desktop, you can open the Blue Prism Cloud Digital Workforce application.

 1. Double click the Blue Prism desktop icon.

Blue Prism launches and the Sign in screen displays.

 2. Enter your supplied credentials, (Blue Prism Cloud will provide the initial operator account).

 3. Click Sign in.
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Signing in and out of the machines
When a user logs onto the Management Server after they complete their work, they will need to log out 
of the machine, rather than just disconnect. If they simply disconnect their Windows account is still 
consuming CPU and memory resources.

Signing out
 1. Select the Windows Button from the taskbar.

 2. Click on your name from the top right of the screen.

 3. Select Sign Out.

Force sign out a user
If you have administration privileges for the Digital Worker, you have the capability to sign a user out and 
terminate processes in a user's session. You should be aware that any unsaved work in a user's session 
will be lost if you forcibly sign them out. Blue Prism Cloud recommend that you try to resolve the 
disconnected session by contacting the user directly before forcibly signing them out.

To force sign out a user's session follow the steps below:

 1. Open Task Manager.

 2. Select the Users tab.

 3. Right-click on a user.

 4. Click Sign off.

To kill a process under a user's session:

 1. Open Task Manager.

 2. Select the Users tab.

 3. Expand the required user's node.

 4. Right-click on a process;

 5. Select End task.
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Blue Prism Cloud Listener
For the automation ecosystem to work, a listener is required to be running on the Digital Worker systems 
on an exposed port. This creates a symbolic link with the Management Server allowing the Management 
Server to use the machine as a Digital Worker as part of its digital workforce.

If the listener is not running on a Digital Worker, then the Management Server cannot communicate with 
the resource (Digital Worker) to initiate or control any automations. 

To check if the listener is running on a Digital Worker, you can simply look at the icons in the taskbar on 
the Digital Worker’s desktop to find the below icon –  you can expand this list by clicking on the arrow. 

If this icon is present, it would suggest that the listener is running on this Digital Worker. However, you 
should check that there are no obvious errors by right clicking on this icon and selecting Show from the 
context menu.
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Here you can see no obvious error codes and the number of Active Connections is greater than zero. You 
can also check to see if a Digital Worker is ready to accept automations from the Blue Prism Control 
Room.

In the above image, we can see that our Digital Worker is connected, with no errors and has a highlighted 
blue computer symbol next to the name of the Digital Worker.

How to start the listener on a Digital Worker
From the Digital Worker’s desktop, select either Start Development Worker Listener or Start 
Production Worker Listener.

The respective worker listener batch file should be in the start-up folder of the local virtual.worker 
account or dedicated Active Directory (AD) worker account where the automated process will be running 
on.

How to stop the listener on a Digital Worker
To stop the listener, right click on the icon from the below panel and select Exit.
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Digital Worker maintenance
You should perform regular restarts of each Digital Worker machine. These can be at any frequency you 
wish – Blue Prism recommend restarting the Digital Worker as frequently as is viably possible. 

Once a Digital Worker has been restarted, you will need to log into the virtual.worker account. These 
credentials will be provided as part of the handover package.  Once the machine has been logged in, you 
should check that the listener has been started. This is set to start automatically but should still be 
verified. 

Blue Prism Cloud   | Accessing Your Platform
Digital Worker maintenance | How to stop the listener on a Digital Worker

Commercial in Confidence Page 12 of 21



Logging
Logging is used to record each activity the automated solution completes when running. Logging is of 
great importance to help with debugging a solution. The session logs can hold valuable information to 
help you pinpoint what element of the automated solution is throwing the error. However, this may not 
be the root cause. Further investigation may be required and an attempt to re-produce the error while 
stepping through the processes will help diagnose the problem. 

You can change the logging levels for each Digital Worker.  To do this:

 1. Navigate to System > Resources > Management.

 2. Right-click on a Digital Worker and select Logging Level. From here you can see various logging 
levels and logging information. 

For development of automations, you may consider selecting all stages. This will ensure that every stage 
is logged in the session log.  Please be aware the more logging that is enabled, the more the session logs 
database table will grow.  Blue Prism recommend that full logging is enabled within the development 
environment whilst developing and testing automations. Oonce it has satisfied UAT criteria and been 
migrated to production, the production Digital Workers should be set to a lower level of logging. 

Credentials
The credential store holds all usernames and passwords for each system interacted with as part of 
automated processes along with extra credentials to help with the management of the process 
automations. Each Digital Worker will have its own set of usernames and passwords for each system. To 
view the credentials, select System Manager > Security > Credentials.

Credentials may be different between the development and production environment.
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Environment migration and release
When an automation has passed testing in the development environment it must be migrated to the 
production environment. Migrating the automations between environments requires a release to be 
created from a package.

More information about releases and packages can be found in the Blue Prism online help.

What is a package?
A package is a group of automation dependencies. These dependencies can be:

 • Processes

 • Business Objects

 • Work Queues

 • Calendars

 • Environment Variables

 • Credentials

 • Tiles

 • Dashboards

What is a release?
A release is a version controlled release of the package contents. Although we mention version controlled 
the system for controlling and versioning releases can be chosen using an appropriate naming 
convention of the release file.

Example
 • Process A created in development environment

 • Package called Automation of Process A created to include the dependency Process A

 • A release of the Automation of Process A package is created and called - Automation of Process A 
- V1.0 – 160320170907

 • The release Automation of Process A - V1.0 - 160320170907 is imported into Production

 • Change request received to make a change to Process A

 • Change implemented to Process A in development environment

 • A release of the Automation of Process A package is created and called - Automation of Process A 
- V2.0 – 200320171030

Notice that another package didn't need to be created, but simply another release taken of the package. 
However, should Process A now require an additional object or other dependency as part of the change 
request the below may be followed:

 • Process A created in development environment

 • Package called Automation of Process A created to include the dependency Process A

 • A release of the Automation of Process A package is created and called - Automation of Process A 
- V1.0 – 160320170907

 • The release Automation of Process A - V1.0 - 160320170907 is imported into Production

 • Change request received to make a change to Process A
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 • Change implemented to Process A in development environment

 • Object X created and implemented within Process A

 • The Automation of Process A package is modified to now include the additional Object X 
dependency

 • A release of the Automation of Process A package is created and called - Automation of Process A 
- V2.0 - 200320171030

Creating a package
To create a package follow the steps below:

 1. Navigate to the Releases section of Blue Prism.

 2. Right click on the Package Overview option and select New Package.

The Create Package wizard displays allowing you to give the Package a name and description. The 
wizard will then allow you to Configure the package by included the relevant dependencies.

 3. Click Next followed by Finish – you will be able to see that your package has been created with the 
selected contents.

Package, release, and version control recommendations

Environment backup package
It is always a good idea to have a package that contains all the dependencies in the whole environment 
(processes, objects, work queues, environment variables, credentials) etc.

This is for two main reasons:

 • Acts as a Disaster Recover backup for your automation environment.

 • Can be used to help roll-back.

For more information about backing up and restoring environments, see the Blue Prism online help.
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Rolling back
The rollback process for single objects or processes differs from that required to roll back a full release 
package.  This is because you haven’t taken a backup of the process prior to importing the later version.  It 
is possible for you to export the current version of the process or object, prior to importing the later 
version, then roll back to the file if required.  However, there is a facility in Blue Prism Cloud that allows 
you to export historic versions of an object or process, allowing you to re-import and overwrite the later 
version. 

 1. Navigate to System > Object > History.

 2. Select the required object from the drop-down box.The history of edits to the object display along 
with the applicable edit summary and datetime stamp of when the edits were saved.

 3. Hold CTRL and click on the top two edits (the latest two edits).

Selecting the top two edits will allow you to roll back to the previous version. You can select the top 
edit and any other edit within this list if you wanted to roll back multiple versions.
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 4. Select Compare Selected Business Objects from the right of the screen.
The Business Object Comparison screen displays.

Here you can see After Editing on the right, which is the current version of the object and Before 
Editing on the left which is the older version.

You can also see colour co-ordinated visual summaries – Yellow = Edit, Green = Addition, Red = 
Removal.

 5. Select File > Export Left Side.

The export dialog box displays allowing you to export the older version as an XML file.

 6. Save the XML to the required location.

 7. Import the XML back into Blue Prism.

 8. Ensure when prompted that you select to overwrite the current object with the newly imported 
object.

The same can be done for processes by choosing System > Processes > History.
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Migrating single objects and processes
Whilst you may consider migrating or exporting a single object or process  In addition to migrating a 
release file, you may also consider migrating a single object or process in the form of an XML file.  This 
method of migrating a single object or process is commonly chosen when there is ongoing development 
to the business process but a fix to a singular object or process is required to be migrated. As there is 
ongoing development work to the remainder of the process, it would not be logical to not migrate a 
whole release as this could have unforeseen impacts, but instead would be prudent to take the single file 
which includes the fix. 

Other instances where a single object or process may be chosen to be migrated as a single XML file, are 
when there is ongoing development to a business process and a phased approach to fixes and/or 
enhancements is required.  It is also important to note that if you are having issues with a singular object 
or process then this can be exported as an XML file and attached to an email to your development team 
or should you wish to contact Blue Prism Support.  

Export a single object or process 
To export a single object or process can be achieved for a variety of ways. The first and most straight 
forward is to export the object or process from the Blue Prism menu using the below steps: 

 1. Select File > Export > Process or Object. Select the relevant option for what you want to export.

 2. Click Next.

 3. Select an object or process and click Next.

 4. Choose a destination to save the exported XML file to and click Finish.

Import a single object or process
Importing a single object or process is similar to exporting:

 1. Select File > Import from the main menu.

 2. Browse for the .xml file in your file system.

 3. Continue through the import wizard.
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Schedules
Schedules can be set to start automations automatically based on set times.  

Start the process manually  
There are a few ways to start a process manually. The most common is to drag a process onto a Digital 
Worker or drag a group of Digital Workers onto a process. 

Stop the process manually  
To stop a process, you can simply right click on the running session and choose either: 

 • Immediate Stop – Sends a signal to the Digital Worker to stop all automation activities regardless 
of where it is in the process. It will stop everything that it is currently doing and won’t close any 
applications.

 • Request Stop – The request stop action works in conjunction with a decision stage within the 
automation process. You can use a decision stage with the below content:
IsStopRequested()

This decision stage will then check to see if a user has requested the session to stop. Based on the 
findings, the process can be routed to close any open applications and softly end with no 
disruption.
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Useful information
 • The Digital Workers keyboard language needs to be set to English (United Kingdom) in the current 

form of the automation;

 • If you RDP to a Digital Worker from the Management Server, this will log out the VNC session. 
Once you have disconnected from the RDP session, you will need to unlock the worker by logging 
back in through VNC

 • If you decide to scale your digital workforce, you may consider making some of the below changes 
and configurations: 

 • Ensure that applications and settings are configured consistently, including for example 
security settings, IE settings for trusted sites

 • Run through processes manually and through testing regimes. For example, this will outline 
the requirement to cache any application credentials, cookie settings or add pop-up blockers

 • Interact and Hub when accessed from the management server displays a blank screen. This usually 
means the windows account you have logged into has incorrect Internet Explorer settings. These 
will need to checked and changed as below:

 • Select Settings > Compatibility View Settings > Display intranet sites in Compatibility 
View (This should be un-checked);

 • Re-load the URLs and test again

 • The Internet Explorer setting on the management server will need to be adjusted per 
Windows account.
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Support
If after performing your internal troubleshooting steps, you still require assistance via our Blue Prism 
Cloud Support team, please contact them with the below information to help with a timely and efficient 
response:

 • Any applicable log file outputs from sessions or work queues

 • Any applicable event log files from the relevant Orchestrator Server(s) or Digital Worker(s)

 • Screen shots of any part of the process of concern

 • Screen shots of any Digital Workers where errors are displayed, or application interaction is of 
concern

 • Information regarding the troubleshooting steps taken and any areas you have already 
investigated

 • An understanding of where you believe there is a problem in the automation

Providing a detailed support ticket query can help Blue Prism Cloud Support to provide you with a quick 
and effective response to help resolve your query.

To contact Blue Prism Cloud Support: cloudsupport@blueprism.com.
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